Chiphell - 分享与交流用户体验

 找回密码
 加入我们
搜索
      
查看: 25742|回复: 16

[网络] IPTV与互联网同一条线设置,并开启组播功能。

[复制链接]
发表于 2018-12-22 23:02 | 显示全部楼层 |阅读模式


浙江电信的IPTV采取的是组播形式,而并不是单播形式(单播占用带宽),本人经过不断实践,结合routeros,将组播复制到了局域网,局域网内的私有终端都能播放直播源。本人将脚本奉献出来,希望各位大侠指点!以下设置均基于RouterOS 6.44beta9平台



#设置两个pppoe接口,一个用户互联网(原已经设置),一个用于iptv专网(新增)
/interface pppoe-client
add disabled=no interface=ether1-FTTx name=pppoe-CNNET password=zj010013 \
user=057300398071
浙江电信未作MAC地址与机顶盒绑定,如果绑定了,请用命令操作
interface ethernet set ether1-IPTV mac-address=3C:78:43:7B:96:F6
新增IPTV pppoe接口
add disabled=no interface=ether2-IPTV name=pppoe-IPTV password=111111 user=\
[email protected]
#设置IPTV内网地址,因为需要走同一条线,所以配置在同一个接口Lan5
add address=10.10.124.1/24 comment=IPTVnet interface=ether5-Lan network=\
10.10.124.0
若不配置IPTV内网地址124网段,机顶盒无法使用业务平台登录进行点播(RTSP流地址均为单播地址,浙江电信使用单播模式进行点播)
#新增地址池,用于IPTV认证网段,设置124网段目的就是为了原机顶盒可以正常使用点播功能
/ip pool
add comment=IPTV name=pool_IPTV ranges=10.10.124.2-10.10.124.254
并配置PPPoe本地地址池、远程地址池
add comment=pool_IPTV_Remote name=pool_IPTV_Local ranges=1.1.1.1-1.1.1.254
add comment=pool_IPTV_Remote name=pool_IPTV_Local ranges=1.1.1.1-1.1.1.254
#因为同一个接口无法使用多个dhcp服务器,机顶盒客户端获取IPTV网段只能使用固定IP或者PPPoe等方式进行获取,这里我们设置PPPoe服务器,也可以手动指定固定IP 124网段。
建立一个PPPOE服务器
/interface pppoe-server server
add disabled=no interface=ether5-Lan service-name=IPTVserver
配置ppp模板
/ppp profile
add dns-server=220.189.127.106,220.189.127.107 local-address=pool_IPTV_Local \
name=IPTV remote-address=pool_IPTV
配置PPP账号
/ppp secret
add name=zjf password=111111 profile=IPTV
#因设置了多个PPPOE拨号连接,需要设置策略路由来指向数据进出口方向
标记IPTV路由符号
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=IPTVnet \
passthrough=yes src-address=10.10.124.0/24
不要忘记标记原capsman无线网路由、Lan网段路由符号,否则原来设置的都无法上网
add action=mark-routing chain=prerouting new-routing-mark=WiFinet \
    passthrough=yes src-address=192.168.0.0/24
add action=mark-routing chain=prerouting new-routing-mark=CNNnet \
    passthrough=yes src-address=10.10.128.0/24
yes src-address=10.10.128.0/24
#设置路由伪装,这里设置为全局
/ip firewall nat
add action=masquerade chain=srcnat
#设置静态路由器,PPPOE拨号连接中默认路由,dns等不要打勾,在此加入默认路由表即可
/ip route
add check-gateway=ping distance=1 gateway=pppoe-IPTV routing-mark=IPTVnet
add check-gateway=ping distance=1 gateway=pppoe-CNNET routing-mark=CNNnet
本人的路由器Lan2LTE备用,在此必须加入进去, distance=2
add check-gateway=ping distance=2 gateway=192.168.8.1 routing-mark=CNNnet
无线网也加入进去,网关走pppoe
add check-gateway=ping distance=1 gateway=pppoe-CNNET routing-mark=WiFinet
以上设置均只能让电信的机顶盒在我们内网中走同一条网线进行播放
---------------------------------------------------------------------------------------------------------------------------------
以下设置组播功能,让小米盒子,天猫魔盒,通过安装友窝来收看直播功能。
#设置组播功能,打开IGMP
/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=pppoe-IPTV upstream=yes
add interface=ether5-Lan
其中加入的接口Lan,就是需要组播的接口,也可以将无线桥接接口加入,以方便在无线网中做组播,但是必须打开capsman中模板配置选项中的multicast-helper=full
/caps-man configuration
add channel=channel9 channel.tx-power=18 country=china datapath=datapath1 \
    distance=indoors mode=ap multicast-helper=full name=AP_2.4G security=\
    security1 ssid=Hi-Kidnet
add channel=channel149 channel.tx-power=22 country=china datapath=datapath1 \
    mode=ap multicast-helper=full name=AP_5G security=security1 ssid=\
"Hi-Kidnet 5G"
普通无线设置只需要单独在网卡接口做就可以。
中央一套-1,rtp://233.50.201.1:5140
浙江卫视-2,rtp://233.50.201.27:5140
钱江频道-3,rtp://233.50.201.28:5140
浙江经视-4,rtp://233.50.201.29:5140
教育科技-5,rtp://233.50.201.30:5140
影视文化-6,rtp://233.50.201.31:5140
民生休闲-7,rtp://233.50.201.32:5140
浙江新闻-8,rtp://233.50.201.34:5140
浙江少儿-9,rtp://233.50.201.33:5140
好易购1-10,rtp://233.50.201.76:5140
好易购2-16,rtp://233.50.201.77:5140
中央少儿-28,rtp://233.50.201.14:5140
东方购物-29,rtp://233.50.201.92:5140
央广购物-30,rtp://233.50.201.93:5140
中央二套-31,rtp://233.50.201.2:5140
中央四套-33,rtp://233.50.201.4:5140
中央七套-36,rtp://233.50.201.7:5140
中央十套-39,rtp://233.50.201.10:5140
中央十一套-40,rtp://233.50.201.11:5140
中央十二套-41,rtp://233.50.201.12:5140
中央新闻-42,rtp://233.50.201.13:5140
中央音乐-44,rtp://233.50.201.15:5140
CCTV-NEWS-45,rtp://233.50.201.126:5140
家有购物-46,rtp://233.50.201.90:5140
环球购物-47,rtp://233.50.201.91:5140
东方卫视-61,rtp://233.50.201.68:5140
湖南卫视-62,rtp://233.50.201.52:5140
安徽卫视-63,rtp://233.50.201.62:5140
贵州卫视-64,rtp://233.50.201.69:5140
天津卫视-65,rtp://233.50.201.47:5140
重庆卫视-66,rtp://233.50.201.66:5140
江苏卫视-67,rtp://233.50.201.41:5140
四川卫视-68,rtp://233.50.201.61:5140
云南卫视-69,rtp://233.50.201.46:5140
吉林卫视-70,rtp://233.50.201.48:5140
数码时代-71,rtp://233.50.201.71:5140
东南卫视-72,rtp://233.50.201.58:5140
广东卫视-73,rtp://233.50.201.56:5140
河北卫视-74,rtp://233.50.201.50:5140
黑龙江卫视-75,rtp://233.50.201.42:5140
旅游卫视-76,rtp://233.50.201.55:5140
山东卫视-77,rtp://233.50.201.64:5140
北京卫视-78,rtp://233.50.201.40:5140
湖北卫视-79,rtp://233.50.201.43:5140
辽宁卫视-80,rtp://233.50.201.60:5140
江西卫视-81,rtp://233.50.201.53:5140
青海卫视-82,rtp://233.50.201.65:5140
**卫视-83,rtp://233.50.201.70:5140
陕西卫视-84,rtp://233.50.201.59:5140
兵团卫视-85,rtp://233.50.201.72:5140
山西卫视-86,rtp://233.50.201.51:5140
宁夏卫视-87,rtp://233.50.201.57:5140
河南卫视-88,rtp://233.50.201.44:5140
广西卫视-89,rtp://233.50.201.49:5140
金鹰卡通-90,rtp://233.50.201.73:5140
炫动卡通-92,rtp://233.50.201.74:5140
中国教育-94,rtp://233.50.201.75:5140
深圳卫视-97,rtp://233.50.201.45:5140
央视一套高清-101,rtp://233.50.201.118:5140
浙江卫视高清-102,rtp://233.50.201.100:5140
钱江频道高清-103,rtp://233.50.201.132:5140
浙江经视高清-104,rtp://233.50.201.133:5140
教育科技高清-105,rtp://233.50.201.134:5140
影视文化高清-106,rtp://233.50.201.135:5140
民生休闲高清-107,rtp://233.50.201.136:5140
浙江新闻高清-108,rtp://233.50.201.137:5140
浙江少儿高清-109,rtp://233.50.201.138:5140
北京卫视高清-129,rtp://233.50.201.107:5140
江苏卫视高清-130,rtp://233.50.201.106:5140
中央二套HD-131,rtp://233.50.201.119:5140
中央七套HD-136,rtp://233.50.201.120:5140
中央九套HD-138,rtp://233.50.201.121:5140
中央十套HD-139,rtp://233.50.201.122:5140
中央十二套HD-141,rtp://233.50.201.123:5140
中央十四套HD-145,rtp://233.50.201.124:5140
东方卫视高清-161,rtp://233.50.201.125:5140
湖南卫视高清-162,rtp://233.50.201.103:5140
安徽卫视高清-163,rtp://233.50.201.113:5140
贵州卫视高清-164,rtp://233.50.201.142:5140
天津卫视高清-165,rtp://233.50.201.104:5140
重庆卫视高清-166,rtp://233.50.201.143:5140
四川卫视高清-168,rtp://233.50.201.139:5140
东南卫视高清-172,rtp://233.50.201.146:5140
广东卫视高清-173,rtp://233.50.201.102:5140
河北卫视高清-174,rtp://233.50.201.140:5140
黑龙江高清-175,rtp://233.50.201.115:5140
山东卫视高清-177,rtp://233.50.201.105:5140
湖北卫视高清-179,rtp://233.50.201.114:5140
辽宁卫视高清-180,rtp://233.50.201.141:5140
江西卫视高清-181,rtp://233.50.201.145:5140
河南卫视高清-188,rtp://233.50.201.144:514
新视觉体育HD-191,rtp://233.50.201.109:5140
全纪实HD-192,rtp://233.50.201.111:5140
新视觉剧场HD-193,rtp://233.50.201.110:5140
新视觉娱乐HD-194,rtp://233.50.201.112:5140
深圳卫视高清-197,rtp://233.50.201.101:5140
探索纪录测试-198,rtp://233.50.201.117:5140
高清娱乐测试-199,rtp://233.50.201.116:5140
浙江之声-201,rtp://233.50.201.79:5140
经济频道-202,rtp://233.50.201.81:5140
音乐调频-203,rtp://233.50.201.82:5140
民生资讯-204,rtp://233.50.201.86:5140
交通之声-205,rtp://233.50.201.83:5140
城市之声-206,rtp://233.50.201.85:5140
旅游之声-207,rtp://233.50.201.84:5140
浙江新闻广播-208,rtp://233.50.201.80:5140
直播室1-801,rtp://233.50.201.201:5140
直播室2-802,rtp://233.50.201.202:5140
直播室3-803,rtp://233.50.201.203:5140
直播室4-804,rtp://233.50.201.204:5140
直播室5-805,rtp://233.50.201.205:5140
直播室6-806,rtp://233.50.201.206:5140
直播室7-807,rtp://233.50.201.207:5140
直播室9-809,rtp://233.50.201.209:5140
直播室10-810,rtp://233.50.201.210:5140
直播室11-811,rtp://233.50.201.211:5140
直播室12-812,rtp://233.50.201.212:5140
直播室13-813,rtp://233.50.201.213:5140
直播室14-814,rtp://233.50.201.214:5140
直播室15-815,rtp://233.50.201.215:5140
广电体育频道1-855,rtp://233.50.201.130:5140
广电体育频道2-856,rtp://233.50.201.131:5140
测试SD1-860,rtp://233.50.201.216:5140
测试HD2-861,rtp://233.50.201.217:5140
测试HD3-862,rtp://233.50.201.218:5140
测试SD4-863,rtp://233.50.201.219:5140
测试HD5-864,rtp://233.50.201.224:5140
导视频道-889,rtp://233.50.201.20:5140
发表于 2018-12-22 23:07 | 显示全部楼层
第一次看到有朋友在ROS里面做
而不是在交换机里面设置
发表于 2018-12-22 23:36 | 显示全部楼层
lz把你的拨号id和密码mask掉吧
发表于 2018-12-22 23:41 | 显示全部楼层
mark一下
发表于 2018-12-23 21:13 来自手机 | 显示全部楼层
楼主从光猫到ROS是两根线还是单线复用,电信给配置单线同时走宽带和iptv?
发表于 2018-12-24 09:08 | 显示全部楼层
udpxy 了解一下 楼主
发表于 2018-12-24 09:32 来自手机 | 显示全部楼层
学习一下
发表于 2018-12-24 10:39 来自手机 | 显示全部楼层
本帖最后由 zhongli_1978 于 2019-11-28 11:04 编辑

mark~~~
 楼主| 发表于 2018-12-24 18:54 | 显示全部楼层
sgzj01 发表于 2018-12-23 21:13
楼主从光猫到ROS是两根线还是单线复用,电信给配置单线同时走宽带和iptv?

双线。。。。。。。
发表于 2018-12-24 22:07 来自手机 | 显示全部楼层
jessfee 发表于 2018-12-24 18:54
双线。。。。。。。

那跟我现在用openwrt的igmpproxy+udpxy是一样的,我还以为电信给配置单线了呢。
发表于 2018-12-24 22:08 | 显示全部楼层
电信的IPTV本来是可以无线的,但是机线员都不会帮用户设置的。。
发表于 2018-12-25 08:54 来自手机 | 显示全部楼层
这个管用,先收藏备用,感谢分享
 楼主| 发表于 2018-12-26 21:34 | 显示全部楼层
sgzj01 发表于 2018-12-24 22:07
那跟我现在用openwrt的igmpproxy+udpxy是一样的,我还以为电信给配置单线了呢。 ...

单线也是可以的。要配置VRRP接口
发表于 2020-5-24 15:51 来自手机 | 显示全部楼层
很好的教程,学习一下
 楼主| 发表于 2021-2-11 09:20 | 显示全部楼层
浙江电信不知道还行不行
发表于 2021-2-11 12:03 | 显示全部楼层
jessfee 发表于 2021-2-11 09:20
浙江电信不知道还行不行

利用udpxy代理组播才是最好的方法
发表于 2021-3-22 09:25 | 显示全部楼层
请问楼主如何知道iptv的账号?
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|Chiphell ( 沪ICP备12027953号-5 )沪公网备310112100042806 上海市互联网违法与不良信息举报中心

GMT+8, 2021-10-23 22:22 , Processed in 0.009666 second(s), 9 queries , Gzip On, Redis On.

Powered by Discuz! X3.4

© 2007-2021 Chiphell.com All rights reserved.

快速回复 返回顶部 返回列表