hyes 发表于 2020-5-11 00:30

ROS通过L7解决dns泥水?

本帖最后由 hyes 于 2020-5-11 10:09 编辑

之前说了routeros自动下载规则,进行ip分流以及ip屏蔽。
但是如果dns被泥水了怎么办。除了dnsmap什么的其他的办法,这里来说下自己 通过爬文的出来的通过ros自己来进行dns分流的办法。
##注意

[*]DNS分流只是解决了域名分流问题,分流后1.1.1.1怎么粗去还是要大家显神通啊;
[*]"1024\\.com|chh\\.com" 这个需要大家自己把需要的域名替换即可;
[*]为什么要有两个,是因为我这边域名太多,一条会提示规则太长;
[*]我是通过winbox设置的,下面代码是自己手敲的,如有误,请帮忙指正。谢谢大佬~


-----------------------------------------------------------------------------------------------------------------------------
/ip firewall layer7-protocol
add name=1111dns regexp="1024\\.com|chh\\.com"

add name=1111dns01 regexp="2048\\.com|tang\\.com"
/

/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=to1111dns passthrough=no layer7-protocol=1111dns protocol=udp in-interface=LAN dst-port=53 comment="rerouting to prerouting"
add chain=prerouting action=mark-routing new-routing-mark=to1111dns01 passthrough=no layer7-protocol=1111dns01 protocol=udp in-interface=LAN dst-port=53 comment="rerouting to prerouting01"
/

/ip firewall nat
add chain=dstnat protocol=udp routing-mark=to1111dns action=dst-nat to-addresses=1.1.1.1 to-ports=53
add chain=dstnat protocol=udp routing-mark=to1111dns01 action=dst-nat to-addresses=1.1.1.1 to-ports=53
/


----------------------------------------------------------------------------------------------------------------------


Will 发表于 2020-5-11 09:20

技术贴啊,谢谢 lz 先。

但是这个的前提是 1.1.1.1 没被污染?

hyes 发表于 2020-5-11 10:09

Will 发表于 2020-5-11 09:20
技术贴啊,谢谢 lz 先。

但是这个的前提是 1.1.1.1 没被污染?

确切来说是1.1.1.1你访问得了才行,然后你需要访问的域名才会被正确解析,然后才会被ip正确分流

Will 发表于 2020-5-11 11:45

hyes 发表于 2020-5-11 10:09
确切来说是1.1.1.1你访问得了才行,然后你需要访问的域名才会被正确解析,然后才会被ip正确分流 ...

大神,

ros 已支持DNS转发和DNS over HTTPS (DoH), 什么时候出个教程?

hyes 发表于 2020-5-11 12:09

本帖最后由 hyes 于 2020-5-11 12:14 编辑

Will 发表于 2020-5-11 11:45
大神,

ros 已支持DNS转发和DNS over HTTPS (DoH), 什么时候出个教程?
别,我也小白,这些都是靠搜索来的.
DOH的话,直接在/ip dns 设置就行了,但是...大砖直接把你DOH的拦截了,所以也没用啊。。。

liuleisail 发表于 2020-9-12 21:34

俺直接在pve里面安装了smartdns,然后利用smartdns国内国外进行分流,很简单。
抛弃了ros 七层以及dnsstatic的分流方式。

hyes 发表于 2020-9-12 21:59

liuleisail 发表于 2020-9-12 21:34
俺直接在pve里面安装了smartdns,然后利用smartdns国内国外进行分流,很简单。
抛弃了ros 七层以及dnsstati ...

我这么折腾是想回头老家没有公网ip,直接老家l2tp连接这边就好。折腾玩

hyes 发表于 2020-9-12 22:11

liuleisail 发表于 2020-9-12 21:34
俺直接在pve里面安装了smartdns,然后利用smartdns国内国外进行分流,很简单。
抛弃了ros 七层以及dnsstati ...

我这么折腾是想回头老家没有公网ip,直接老家I2tp连接这边就好。折腾玩

liuleisail 发表于 2020-9-12 22:12

有道理,老人家也没有公网ip,搭建一个l2tp去
页: [1]
查看完整版本: ROS通过L7解决dns泥水?