Chiphell - 分享与交流用户体验

 找回密码
 加入我们
搜索
      
查看: 38186|回复: 70

[NAS] HP MicroServer Gen8升级最新BIOS及iLO 1.51固件,风扇转速测试

[复制链接]
发表于 2014-7-21 09:38 | 显示全部楼层 |阅读模式
本帖最后由 tedaz 于 2017-2-17 21:31 编辑

HP MicroServer Gen8升级最新BIOS及iLO 1.51固件,风扇转速测试

众所周知,HP的MicroServer Gen8在B120i的AHCI SATA模式下,有风扇转速过高的问题,详见HP ProLiant MicroServer Gen8迷你服务器 汇总贴:降噪、升级、改造

依照国外论坛和美国HP官方论坛的帖子显示,很多老外在MSG8发布之初就开始通过各种渠道积极联系HP,尝试寻找解决方案。
经过一年多的努力,HP终于再次发布MSG8的新版BIOS及iLO 1.51。依照官方文件显示这套固件可以降低AHCI SATA模式下的风扇转速。

下面是本人MSG8从破解版iLO 1.32升级到官方版1.51的过程及风扇转速截图。
注1:此前有高人将iLO 1.32固件破解,此破解版iLO固件可以将AHCI SATA模式下的风扇转速降低40%左右。
注2:MSG8在RAID模式下无任何风扇转速问题,相当完美。若您的MSG8设置为RAID模式,请忽略这里关于风扇转速的讨论。

背景:
  • MSG8主板集成的软RAID卡为B120i,同时主板集成了iLO。系统风扇由iLO控制;控制依据来源于多个系统温度传感器,其中包括iLO通过B120i获取的硬盘温度。
  • 仅当B120i工作在RAID模式时,iLO才能获取硬盘温度,并依照温度调控风扇转速。
  • 当B120i工作在AHCI SATA模式时,iLO无法获取硬盘温度,从而假设最坏的情况发生,会大大提高风扇转速。HP官方已经明确表示肯定无法让iLO在SATA模式读取硬盘温度。这意味着iLO此时必须盲控风扇,而不是依照硬盘温度调整风扇转速。
  • 在环境温度25℃时,RAID模式下风扇转速约为8%,相同配置在AHCI SATA模式下风扇转速约为40%。(因为不知道硬盘温度,所以iLO只能以最保守的方式——极大程度的提高风扇转速,来保证硬件的安全。但通常不需要这么高的风扇转速。)
  • 所以,此前有高人将iLO 1.32破解,强行将AHCI SATA模式的默认风扇转速下降40%(比如将40%的风扇转速下降40%后的风扇转速约为16%左右)。

破解版iLO v1.32:http://pan.baidu.com/s/1nt6wOfn
官方iLO v1.51:http://pan.baidu.com/s/1hGM7s


先看一下使用破解的iLO 1.32时的情况
50.PNG

传感器显示:环境温度34℃(不开空调,北京最近就这温度),系统排出温度53℃。
10.PNG

此时系统风扇的转速为29%。已经可以非常明显的听到风扇噪音了。本人的MSG8放在客厅,晚上如果不关卧室门,在我是也是可以听到风扇的声音的。
20.PNG

开始准升级固件。在Administration页面的Firmware中浏览选中ilo4_151.bin,并点击确认,开始升级。
60.PNG
70.PNG

开始上传固件:
80.PNG

然后iLO会验证固件的签名:
81.PNG

之后就开始刷新固件了:
82.PNG

刷新完成,等一会iLO会自动重启。(windows系统不需要重启)
iLO的登录页面已经显示固件为1.51了
83.PNG

到系统信息页面查看,固件升级成功。(注:此前BIOS已经更新为最新的J06 06/06/2014。)
05.PNG

看一下1.51下的风扇转速为:45%!!!
暴力啊!~
85.PNG

传感器显示:环境温度33℃,系统排出温度50℃。排出温度较前降低了3℃,这主要是因为风扇转速从29%提升到45%导致的。
86.PNG

结论:经过实际测试,新版的BIOS及iLO 1.51并没有像HP官方所说的大大降低风扇转速。
发表于 2014-7-21 10:32 | 显示全部楼层
本帖最后由 wish 于 2014-7-21 10:34 编辑

看来固件还没有把问题解决
随带求共享一下iLO 1.51固件
发表于 2014-7-21 11:54 | 显示全部楼层
如果官方明确不能在AHCI SATA下获得传感器温度,那么这个问题始终是没法完美结局的,sigh。。。
 楼主| 发表于 2014-7-21 12:02 | 显示全部楼层
wish 发表于 2014-7-21 10:32
看来固件还没有把问题解决
随带求共享一下iLO 1.51固件

已经上了链接
 楼主| 发表于 2014-7-21 12:02 | 显示全部楼层
flashermaster 发表于 2014-7-21 11:54
如果官方明确不能在AHCI SATA下获得传感器温度,那么这个问题始终是没法完美结局的,sigh。。。 ...

没错。现在只是某种程度的“暴力”降低风扇转速而已。
发表于 2014-7-21 12:07 | 显示全部楼层
tedaz 发表于 2014-7-21 12:02
没错。现在只是某种程度的“暴力”降低风扇转速而已。

现在看来您发的另一帖的那个思路比较有意思,不如换一个静音风扇
发表于 2014-7-21 12:39 | 显示全部楼层
这个要支持,多谢兄弟的测试,我暂时就不折腾了,期待国外能折腾出1.51版的破解固件。
 楼主| 发表于 2014-7-21 13:01 | 显示全部楼层
flashermaster 发表于 2014-7-21 12:07
现在看来您发的另一帖的那个思路比较有意思,不如换一个静音风扇

已经有老外用那个办法换了猫头鹰的12cm风扇,据说也会保持在较高的转速,不过好在猫头鹰的风扇比Hp的原装风扇安静。
 楼主| 发表于 2014-7-21 13:02 | 显示全部楼层
terryborg 发表于 2014-7-21 12:39
这个要支持,多谢兄弟的测试,我暂时就不折腾了,期待国外能折腾出1.51版的破解固件。 ...

我一直在找具体的破解方法,特别是如何解包固件、重新签名,可惜找不到。估计1.32的破解版是HP的内部人弄的。
发表于 2014-7-21 13:05 来自手机 | 显示全部楼层
29%都觉得很暴力了,45%就没法想象
发表于 2014-7-21 13:42 | 显示全部楼层
楼主混那个PT啊~!
发表于 2014-7-21 13:55 | 显示全部楼层
对于我现在只是做纯nas,觉得最好的方法就是定速风扇,现在用sony的12cm的扇子,加了个47欧2W的电阻,转速在700左右,几乎没有声音
发表于 2014-7-21 15:17 | 显示全部楼层
使用raid,更新1.51固件,风扇6% 但是cpu温度一直有问题,从之前的1.4固件到1.51,一直显示40度。
 楼主| 发表于 2014-7-21 15:43 | 显示全部楼层
zibo2002 发表于 2014-7-21 13:05
29%都觉得很暴力了,45%就没法想象

毕竟MicroServer的名字中有Server,就算不如机架式服务器暴力,也毕竟算是server级的暴力扇,自己想象吧
 楼主| 发表于 2014-7-21 15:44 | 显示全部楼层
bian7 发表于 2014-7-21 13:42
楼主混那个PT啊~!

现在PT凋零的厉害啊,就剩mteam和hdwing了。
 楼主| 发表于 2014-7-21 15:44 | 显示全部楼层
lluu131 发表于 2014-7-21 13:55
对于我现在只是做纯nas,觉得最好的方法就是定速风扇,现在用sony的12cm的扇子,加了个47欧2W的电阻,转速 ...

如何连接是的服务器不报警呢?
 楼主| 发表于 2014-7-21 15:47 | 显示全部楼层
InSee 发表于 2014-7-21 15:17
使用raid,更新1.51固件,风扇6% 但是cpu温度一直有问题,从之前的1.4固件到1.51,一直显示40度。 ...

温度传感器01的环境温度是多少?
看国外论坛的讨论,CPU长期40℃应该并不是什么bug,似乎也是iLO的设计初衷而已,并且那玩意儿也不是真的一直40℃,我的有时会显示高于40的。当然即使显示高于40,和aida之类显示的温度也是不同的。
发表于 2014-7-21 17:30 | 显示全部楼层
tedaz 发表于 2014-7-21 15:47
温度传感器01的环境温度是多少?
看国外论坛的讨论,CPU长期40℃应该并不是什么bug,似乎也是iLO的设计初 ...


01环境温度开了空调,27度。
不过chipset和LOM温度一直蛮高的。

2.jpg

另外升级了iLO1.51后,系统的ROM没有一起更新,我是下载的ISO一起更新的,可能还要单独更新下system rom
1.jpg
发表于 2014-7-21 18:58 | 显示全部楼层
InSee 发表于 2014-7-21 17:30
01环境温度开了空调,27度。
不过chipset和LOM温度一直蛮高的。

cp023765 HP ProLiant System ROM 06-06-2014.exe
http://pan.baidu.com/s/1hqiQ37Q
发表于 2014-7-21 19:26 | 显示全部楼层
wish 发表于 2014-7-21 18:58
cp023765 HP ProLiant System ROM 06-06-2014.exe
http://pan.baidu.com/s/1hqiQ37Q

谢谢wish, 升级ok
发表于 2014-7-22 09:20 | 显示全部楼层
本帖最后由 wish 于 2014-7-22 14:11 编辑

QQ图片20140722091219.jpg

QQ图片20140722091135.jpg

我简单反馈一下,新的固件真的略减低风扇转速。。
现在广东这边在35度左右不是空调房,对上一个版本iLO 1.4这温度风扇转速在50%左右。更新了iLO 1.51后刚开机40%,过一段时间后已经降到36%持续

 楼主| 发表于 2014-7-22 12:46 | 显示全部楼层
wish 发表于 2014-7-22 09:20
我简单反馈一下,新的固件真的大幅度减低风扇转速。。
现在广东这边在35度左右不是空调房,对上一个版 ...

在这种环境下,如果使用破解的1.32估计也就19%甚至更低;如果将B120i设置为RAID,估计也就8%。所以新版固件只能说有些许下降,距离官方说的“大幅”下降还有很大距离。
发表于 2014-7-22 14:11 | 显示全部楼层
tedaz 发表于 2014-7-22 12:46
在这种环境下,如果使用破解的1.32估计也就19%甚至更低;如果将B120i设置为RAID,估计也就8%。所以新版固 ...

好吧我改一下略下降....
破解的我暂时没有刷过,因为我要光驱位启动。我测试的环境下降了14%,可以接受


 楼主| 发表于 2014-7-22 14:12 | 显示全部楼层
wish 发表于 2014-7-22 14:11
好吧我改一下略下降....
破解的我暂时没有刷过,因为我要光驱位启动。我测试的环境下降了14%,可以 ...

破解的仅改变了风扇转速,其他没变,和光驱启动没关系的。
发表于 2014-7-22 14:43 | 显示全部楼层
tedaz 发表于 2014-7-22 14:12
破解的仅改变了风扇转速,其他没变,和光驱启动没关系的。

https://www.chiphell.com/forum.php?mod=viewthread&tid=1034711&extra=page%3D1%26filter%3Dtypeid%26typeid%3D479
QQ图片20140722144155.jpg


terryborg提到无法设置从光驱位硬盘启动系统,我看到后就没刷了
发表于 2014-7-22 15:36 | 显示全部楼层
本帖最后由 terryborg 于 2014-7-22 15:39 编辑

兄弟可能是没有理解我的意思,可能我的语文是数学老师教的,我说的是硬盘设置为AHCI和raid的对比,风扇问题一直是在AHCI模式下有问题,如果是Raid模式下,那是没有风扇问题的。(只是硬盘在raid模式下无法休眠,和需要重新初始化,硬盘数据会全部清除,这对于24小时开机的我来说无法接受,而且楼上的汇总帖子里也有ahci下光驱位硬盘启动的方法)
硬盘启动和iol版本没有任何关系。
 楼主| 发表于 2014-7-22 15:42 | 显示全部楼层
wish 发表于 2014-7-22 14:43
https://www.chiphell.com/forum.php?mod=viewthread&tid=1034711&extra=page%3D1%26filter%3Dtypeid%26ty ...

其实Gen8只要设置为SATA模式,就只能从第一个sata口引导,和bios、iLO的版本没关系的。
以前发过一个AHCI SATA模式下,用u盘来引导第五个SATA口的SSD的帖子。

总而言之,现在所有关于bios、iLO固件的讨论,都是基于B120i的AHCI SATA模式的,不是RAID模式。而且任何版本的固件均不影响启动问题;不同版本固件都是一群狂热爱好者在折腾AHCI模式下的风扇,仅此而已。
发表于 2014-7-22 18:18 | 显示全部楼层
本帖最后由 zhangjun5103 于 2014-7-22 18:22 编辑

求救啊,为什么我的风扇一直是50%,我是四盘RAID0,已刷1.51,Win2008 R2。


1.jpg



2.jpg

3.jpg

发表于 2014-7-22 20:02 | 显示全部楼层
zhangjun5103 发表于 2014-7-22 18:18
求救啊,为什么我的风扇一直是50%,我是四盘RAID0,已刷1.51,Win2008 R2。

这四盘Raid0风险太大了吧,是不是应该单独单盘Raid0呢。
发表于 2014-7-22 20:26 | 显示全部楼层
InSee 发表于 2014-7-22 20:02
这四盘Raid0风险太大了吧,是不是应该单独单盘Raid0呢。

    刚买GEN8,目前是实验学习阶段,暂时也不准备放重要数据,就搞了单位四块淘汰500G硬盘试用,等都学习完了,搞几块大硬盘再单独Raid0。只是建了Raid后风扇转速远没有达到理想的状态。
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|Chiphell ( 沪ICP备12027953号-5 )沪公网备310112100042806

GMT+8, 2019-10-22 20:18 , Processed in 0.017325 second(s), 16 queries , Gzip On, Redis On.

Powered by Discuz! X3.1

© 2007-2019 Chiphell.com All rights reserved.

快速回复 返回顶部 返回列表