Chiphell - 分享与交流用户体验

 找回密码
 加入我们
搜索
      
查看: 11439|回复: 44

[NAS] Gen8远程挂载SPP镜像执行自动固件更新后HPIP怎么还是原版本?

[复制链接]
发表于 2018-5-6 17:32 | 显示全部楼层 |阅读模式
本帖最后由 红色狂想 于 2018-5-6 17:44 编辑

自从16年10月份入手了Gen8后就一直没怎么折腾,固件还是出厂预装的版本。昨天晚上挂载P03093_001_spp-Gen8.1-SPPGen81.4.iso镜像准备将所有固件更新到最新版,以便后续安装Windows Server 2016
更新时选择的Automatic Firmware Upgrade,一路很顺利

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (3).PNG

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (4).jpg

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (5).PNG

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (6).PNG

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (7).PNG

捕获iLO 4 ProLiant MicroServer Gen8 - Firmware Upgrade (8).PNG

捕获iLO 4 ProLiant MicroServer Gen8 登录界面.jpg

捕获iLO 4 ProLiant MicroServer Gen8 访问设置 - 语言.PNG

但是当登录iLO4查看更新后的固件版本信息时发现有几个固件还是以前的版本啊,比如Intelligent Provisioning还是1.62.14,安装时明明选择的是自动更新,为什么有些固件会忽略不更新呢,难道因为当前系统上已经安装了2008 R2的原故?
这是启动进入Intelligent Provisioning的界面

捕获iLO 4 ProLiant MicroServer Gen8 - Intelligent Provisioning.PNG

下图为更新后的固件版本信息

捕获iLO 4 ProLiant MicroServer Gen8 固件版本信息.PNG

更新前的固件版本信息

捕获iLO 4 ProLiant MicroServer Gen8 固件版本信息2.PNG
发表于 2018-5-6 17:41 | 显示全部楼层
你去看SPP的包含列表嘛,不包括HPIP。
HPIP的镜像是HPIP162.2015_0325.33.iso这种,去hpe上找找看吧。
发表于 2018-5-6 21:12 | 显示全部楼层
本帖最后由 pugk 于 2018-5-6 21:55 编辑

到官方驱动,软件,固件下载页,收到介质恢复下载项,点历史就有各版本链接!
刷了可以到iL〇的web页,交换r〇m变回原来版本!详情可看我发过的贴子https://www.chiphell.com/forum.p ... peid%26typeid%3D737
 楼主| 发表于 2018-5-6 21:15 | 显示全部楼层
monkeylab 发表于 2018-5-6 17:41
你去看SPP的包含列表嘛,不包括HPIP。
HPIP的镜像是HPIP162.2015_0325.33.iso这种,去hpe上找找看吧。 ...

汗,竟然忘了,HPIP是单独发行的。。。
发表于 2018-5-6 21:25 | 显示全部楼层
Spp就8.1最高版!ip最新1.7版,但我升了ip17版不知是坏了还是版本问题,连2008装好后没能识别为HP的专用网卡
发表于 2018-5-6 21:35 | 显示全部楼层
IP是单独的,这个机器应该还是用1.X的IP,不能升级到2.X版本。
发表于 2018-5-6 21:47 | 显示全部楼层
本帖最后由 pugk 于 2018-5-7 08:47 编辑

https://support.hpe.com/hpsc/swd ... id=4184#tab-history 介质链接
在:Revision History 处可以找到不到版本的链接
在:Installation建议,处可以找到该版本的安装方法(不同版本有所不同,1.63挂cd可以,1.7要制块门u盘工具)
你要了解什么叫沉余rom机制才去刷!要不越刷可能越坏可能,要是当前已变坏了
https://www.chiphell.com/forum.p ... peid%26typeid%3D737

2)我看过好几个贴说ip坏了,也没看到建议切换一下备份rom试试行不的问题,大多数是说直接刷ip .
  我的理解双rom机制下刷ip是这样的,假设A区为当前区,B区为备份区,他们的版本分别是c1,C0 (c0为c1之前的备份),那当我们刷rom时,系统是把c1版本存到B区,然后把c1升为c2。
    发现c1有问题,可以把c0切换到A区来能不能用
    要是c0版本能用,c1不能用,就得在正常能用的rom下刷,才能保证刷完后的备份rom是可用的(备分就是你刷下前的版本)。要不越刷可能越杯具了




在iLo的web页面的信息菜单,诊断项
发表于 2018-5-6 22:39 来自手机 | 显示全部楼层
我也想知道
 楼主| 发表于 2018-5-7 21:45 | 显示全部楼层
pugk 发表于 2018-5-6 21:12
到官方驱动,软件,固件下载页,收到介质恢复下载项,点历史就有各版本链接!
刷了可以到iL〇的web页,交换 ...

你说的介质恢复下载项是这个链接吗 https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291&swItemId=MTX_67851618d0f1444993f262f0f6&swEnvOid=4184#tab-history
这个Intelligent Provisioning Recovery Media是HPIP更新镜像呀还是更新出现问题后的恢复镜像啊?
 楼主| 发表于 2018-5-7 22:07 | 显示全部楼层
pugk 发表于 2018-5-6 21:25
Spp就8.1最高版!ip最新1.7版,但我升了ip17版不知是坏了还是版本问题,连2008装好后没能识别为HP的专用网 ...

P03093_001_spp-Gen8.1-SPPGen81.4就是8.1版吧,这个是完全支持HP ProLiant MicroServer Gen8的吧,不存在兼容性问题
IP最新的1.7版就是HPIP170.2017_1006.67.iso这个镜像吧?
有坛友在另一篇帖子中说1.64.1的IP进界面很快,比1.63快很多,他安装server 2016都正常,运行到现在很稳定。
我想安装1.64.1版,这个比1.7版应该更可靠一些吧,毕竟最新版或多或少会存在些问题,不求最新,只要能顺利安装server 2016就行
 楼主| 发表于 2018-5-7 22:16 | 显示全部楼层
c2h6o 发表于 2018-5-6 21:35
IP是单独的,这个机器应该还是用1.X的IP,不能升级到2.X版本。

嗯,如果不是因为想用server 2016我是不会冒险更新固件的,就怕出现各种兼容性问题,服务器图的就是可靠稳定。不追求最新版,2.X的就不要了,只安装完全支持HP ProLiant MicroServer Gen8的,看到有坛友在另一篇帖子中说1.64.1的IP进界面很快,比1.63快很多,安装server 2016也都正常,运行到现在很稳定。我准备安装1.64.1版,你觉得怎么样?
 楼主| 发表于 2018-5-7 22:44 | 显示全部楼层
pugk 发表于 2018-5-6 21:47
https://support.hpe.com/hpsc/swd ... id=4184#tab-history 介质链接
在:Revision History 处可以找到不 ...

非常感谢!你的攻略帖子我看过了,通读两遍后受益匪浅,特别是知道了冗余ROM这个功能,真是给自己留条后路是不幸中的万幸啊,看来要养成以后每次更新新固件前先交换一下ROM这个好习惯了,以便保持当前固件是最原始版的正常固件,这样每次更新后备用ROM中备份的都是那个最原始的正常版本。
再问一下,冗余ROM中保存着Gen8的所有固件吗,是不是只要一进行交换ROM,下图中的10个固件都恢复到以前的版本了?

捕获iLO 4 ProLiant MicroServer Gen8 固件版本信息.PNG

捕获iLO 4 ProLiant MicroServer Gen8 冗余 ROM 支持.PNG
 楼主| 发表于 2018-5-7 22:49 | 显示全部楼层

HPIP是单独发行的,需要另外下载安装,选择1.64.1版就行了
发表于 2018-5-8 11:19 | 显示全部楼层
本帖最后由 pugk 于 2018-5-8 11:30 编辑

要是不交换rom刷的话就没有最原始的版本,只有对上一次更新的版本。你想要跳级的低版有时只能刷降级版。
你知你用过linksys的路由没有,每次刷rom,我得回到官方的版去刷升级,另一则不断升,备用的官方固件不会补刷掉
双rom号称刷不死,但年中也有很多不幸的群众,不知情下,刷了接着又再刷下,结果要是刷了一个杯具的rom后就玩蛋了
-----
刷rom是要交换,但固件升可以web直接上传(是在现有rom上升的级吧??我理解)
发表于 2018-5-8 11:59 | 显示全部楼层
bios和ip两个概念,存放介质也不一样,主备bios放在spi flash里面,ip放nand里面。其实只要ip能支持你要安装的系统即可,不用频繁刷,坏块多了就容易出问题。
发表于 2018-5-8 12:05 | 显示全部楼层
alone 发表于 2018-5-8 11:59
bios和ip两个概念,存放介质也不一样,主备bios放在spi flash里面,ip放nand里面。其实只要ip能支持你要安 ...

BIOS gen8就2个版本,新版我也刷了。要制u盘刷。但bios也是放在不同的ip介质中的(没搞清要交换不了),你可以存在2个不同bios的
发表于 2018-5-8 12:32 | 显示全部楼层
pugk 发表于 2018-5-8 12:05
BIOS gen8就2个版本,新版我也刷了。要制u盘刷。但bios也是放在不同的ip介质中的(没搞清要交换不了), ...

红框部位就是bios,ip不是安装在这里的
gen.jpg
发表于 2018-5-8 13:01 | 显示全部楼层
本帖最后由 pugk 于 2018-5-8 13:22 编辑
alone 发表于 2018-5-8 12:32
红框部位就是bios,ip不是安装在这里的

我有升级过bios,之后乱搞下rom坏了,按f9,f10都没反应了,后来发现可以切换rom
发现bios降低版了,也就是说bios也是双份的,它与ip的关系是可以交叉?还是一对一对应,没搞清?
发表于 2018-5-8 13:09 | 显示全部楼层
本帖最后由 pugk 于 2018-5-8 13:19 编辑

电脑可能中毒了,重装过之后,找了几遍iLo的web管理页面也找不到当时装的那个win端的 IRC 远程集成安装?因为web弹出那个IRC 时间长了会断线。也不用进入web页。
晢时找不到安装文件在那可以下载?
 楼主| 发表于 2018-5-8 15:37 | 显示全部楼层
本帖最后由 红色狂想 于 2018-5-8 15:38 编辑
pugk 发表于 2018-5-8 11:19
要是不交换rom刷的话就没有最原始的版本,只有对上一次更新的版本。你想要跳级的低版有时只能刷降级版。
你 ...

我Gen8买来固件版本就是下图这样,前天第一次通过iLO4 Web IRC挂载P03093_001_spp-Gen8.1-SPPGen81.4.iso镜像将固件更新到最新版,这样备用ROM保存的就是原官方固件吧?
那么当以后再更新固件时,正确的做法就是先进行交换ROM操作,将当前活动ROM恢复为原官方固件,这样当再次更新固件时备用ROM中保存的依然还是最初的原官方固件

 楼主| 发表于 2018-5-8 16:06 | 显示全部楼层
alone 发表于 2018-5-8 11:59
bios和ip两个概念,存放介质也不一样,主备bios放在spi flash里面,ip放nand里面。其实只要ip能支持你要安 ...

嗯,时间长没折腾忘了,固件我不追新,只要稳定能正常支持要安装的操作系统就行了。IP我想安装1.64.1版,貌似你用的就是这个版本吧,当初通过IP安装部署Server 2016过程中有提示Windows没有发现Microsoft的许可条款导致安装中断等现象吗,还有所有的HP官方驱动IP也都能自动打上吗?
安装1.64.1版需要制备U盘吗,还是和SPP一样只要将HPEIP镜像下载下来通过IRC挂载重启F11选择CD-ROM启动就自动安装好了?
 楼主| 发表于 2018-5-8 16:11 | 显示全部楼层
pugk 发表于 2018-5-8 13:09
电脑可能中毒了,重装过之后,找了几遍iLo的web管理页面也找不到当时装的那个win端的 IRC 远程集成安装? ...

换一台PC登录iLO4 Web试试啊
发表于 2018-5-8 16:49 | 显示全部楼层
红色狂想 发表于 2018-5-8 16:06
嗯,时间长没折腾忘了,固件我不追新,只要稳定能正常支持要安装的操作系统就行了。IP我想安装1.64.1版, ...


对,我就这个ip,安装ip的时候直接挂载镜像更新的,另外安装2016没发生这个问题,2016镜像用的itellyou上的
发表于 2018-5-8 19:02 | 显示全部楼层
alone 发表于 2018-5-8 16:49
对,我就这个ip,安装ip的时候直接挂载镜像更新的,另外安装2016没发生这个问题,2016镜像用的itellyou上 ...

微软官方2012,2016的180天版在ip下就是到最后不是提示没许可,就是2016在ip的打驱动cmd窗口中报错退出。
发表于 2018-5-8 19:02 | 显示全部楼层
红色狂想 发表于 2018-5-8 16:11
换一台PC登录iLO4 Web试试啊

不知是不是要重装输入激活??
发表于 2018-5-8 19:05 | 显示全部楼层
红色狂想 发表于 2018-5-7 21:45
你说的介质恢复下载项是这个链接吗 https://support.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5390291& ...

这个是刷rom版,你想那版就刷那版,可能不同版不同安装方法,具体看说明
 楼主| 发表于 2018-5-9 14:02 | 显示全部楼层
alone 发表于 2018-5-8 16:49
对,我就这个ip,安装ip的时候直接挂载镜像更新的,另外安装2016没发生这个问题,2016镜像用的itellyou上 ...

我在论坛里只找到了HPIP164B.2017_0201.3.iso版的IP,这个164B就是1.64.1版吗,为什么后面是个B而不是1?
另外,以下HPE官网上这两个Intelligent Provisioning Recovery Media下载就是正版IP的镜像吗?
HPIP164B.2017_0201.3.iso (886 MB)
HPIP164.2017_0113.129.iso (885 MB)
 楼主| 发表于 2018-5-9 14:06 | 显示全部楼层
pugk 发表于 2018-5-8 19:02
不知是不是要重装输入激活??

重装什么,Gen8中的Windows系统,还是ROM恢复出厂设置?
 楼主| 发表于 2018-5-9 14:09 | 显示全部楼层
pugk 发表于 2018-5-8 19:05
这个是刷rom版,你想那版就刷那版,可能不同版不同安装方法,具体看说明 ...

那哪个页面才是下载正式版HPIP1641镜像的链接呀?
发表于 2018-5-9 14:14 | 显示全部楼层
红色狂想 发表于 2018-5-9 14:06
重装什么,Gen8中的Windows系统,还是ROM恢复出厂设置?

打错,是重新输入那个激活号?
就是记不起怎么装的那个win 版的远程控制集成程序了
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|Chiphell ( 沪ICP备12027953号-5 )沪公网备310112100042806

GMT+8, 2020-3-31 17:19 , Processed in 0.018399 second(s), 26 queries , Gzip On.

Powered by Discuz! X3.1

© 2007-2019 Chiphell.com All rights reserved.

快速回复 返回顶部 返回列表